Announcements

Oracle training based on real-time expertise as per industry standards. Upcoming batch details are here.

View batch schedule

Free Oracle mock interview. Register using the link.

Register

#DBAchallenge: submit your questions.

Ask questions
Swipe for more →
Browse by Topic
Latest Posts

    Monday, September 27, 2021

    sqlplus and rman and other binary executable are not working with error while loading shared libraries: libclntshcore.so.12.1: cannot open shared object file: No such file or directory

    Issue:

    sqlplus and rman and other binary executable are not working with error while loading shared libraries: libclntshcore.so.12.1: cannot open shared object file: No such file or directory

     
    Error Message:

    /orasw/oracle/product/12.1.0.2/db/bin/sqlplus: error while loading shared libraries: libclntshcore.so.12.1: cannot open shared object file: No such file or directory
    /orasw/oracle/product/12.1.0.2/db/bin/rman: error while loading shared libraries: libclntshcore.so.12.1: cannot open shared object file: No such file or directory

    [oracle@oracledb lib]$ sqlplus / as sysdba
    sqlplus: error while loading shared libraries: libclntshcore.so.12.1: cannot open shared object file: No such file or directory

    [oracle@oracledb lib]$ rman target /
    rman: error while loading shared libraries: libclntshcore.so.12.1: cannot open shared object file: No such file or directory
    [oracle@oracledb lib]$

    Cause:

    After Inverstigating found that the shared object file libclntshcore.so.12.1 was missing from the lib(/orasw/oracle/product/12.1.0.2/db/lib) location.

    Solution:

    [oracle@oracledb lib]$ pwd
    /u01/app/oracle/product/12.2.0.1/dbhome_1/lib
    [oracle@oracledb lib]$ ls -lrtr libclntshcore.so.12.1
    ls: cannot access libclntshcore.so.12.1: No such file or directory
    [oracle@oracledb lib]$

    Copy from the existing Oracle Home and verify the file exist and has proper permission

    [oracle@oracledb lib]$ ls -lrtr libclntshcore.so.12.1
    -rwxr-xr-x. 1 oracle oinstall 8032696 Sep 27 19:28 libclntshcore.so.12.1
    [oracle@oracledb lib]$

    [oracle@oracledb lib]$ sqlplus / as sysdba

    SQL*Plus: Release 12.2.0.1.0 Production on Mon Sep 27 19:29:18 2021

    Copyright (c) 1982, 2016, Oracle.  All rights reserved.


    Connected to:
    Oracle Database 12c Enterprise Edition Release 12.2.0.1.0 - 64bit Production

    SQL> Disconnected from Oracle Database 12c Enterprise Edition Release 12.2.0.1.0 - 64bit Production
    [oracle@oracledb lib]$ rman target /

    Recovery Manager: Release 12.2.0.1.0 - Production on Mon Sep 27 19:29:24 2021

    Copyright (c) 1982, 2017, Oracle and/or its affiliates.  All rights reserved.

    connected to target database: ORA12C (DBID=457334020)

    RMAN>

    Recovery Manager complete.
    [oracle@oracledb lib]$

    Regards,
    Mallik

    Friday, September 24, 2021

    DBCA fails with errors: [FATAL] [DBT-50000] Unable to check for available memory

    DBCA fails with errors: [FATAL] [DBT-50000] Unable to check for available memory


    Recently I have installed Oracle 19c Database binary to windows machine. And after that I started DBCA to create database.

    In “Configuration options” steps I got memory error. i.e. [DBT-50000] Unable to check for available memory

    Earlier I selected 8GB for my SGA but after this error I had selected 2GB only. But still was facing this issue.

    Here is the screenshot for the same.
     


    After searching oracle docs for known issue, I found, it’s a bug. One can find details about this bug on following oracle notes.

    DBCA fails with errors: [FATAL] [DBT-50000] Unable to check for available memory in “Specify configuration option” (Doc ID 2631718.1)

    Workaround for this issue is,

    Run dbca with “-J-Doracle.assistants.dbca.validate.ConfigurationParams=false” like a bellow command,

    Open CMD (Run as Administrator)
    Run database configuration assistant with the following command
    dbca -J-Doracle.assistants.dbca.validate.ConfigurationParams=false

    Regards,
    Mallik

    Monday, September 20, 2021

    19c Oracle DBA Training || 30-Sep-2021 New Batch || Course Details & Demo Classes



    Oracle Database Training!!! - 19c Oracle Database Training!!!

    New DBA batch is starting on 30-Sep-2021. Don't forget to attend Demo classes on 30-Sep-2021 & 01-Oct-2021. 

    Ping me on my WhatsApp Number +91 9880616848 for registration & more details.

    Attend Demo Classes using below zoom Meeting:

    https://us02web.zoom.us/j/86254664197?pwd=QVVCdEdVVlRoREQ2RGdYQUZyVVNFUT09

    Timing: 

    Sep 30, 2021 09:00 AM IST to 11:00 AM IST
    Oct 01, 2021 09:00 AM IST to 11:00 AM IST

    Check out this video for more details on course content:

    https://youtu.be/BANrqNLiZqo

    Check the below link for Course details:

    https://mallik034.blogspot.com/p/database-training.html

    Check the below link for Couse registration and Timing and fees details:

    https://mallik034.blogspot.com/p/upcoming-batch-schedule.html

    #19c #DBA #oracle #database #training #course #announcement #CareerOpportunities

    Regards,
    Mallik



    Wednesday, September 1, 2021

    Manually Drop RAC Database and Remove From Clusterware

    Manually Drop RAC Database and Remove From Clusterware


    1. Verify RAC database status:

    [oracle@oraclenode1 ~]$ . oraenv
    ORACLE_SID = [oracle] ? RACSB1
    The Oracle base has been set to /u01/app/oracle
    [oracle@oraclenode1 ~]$ srvctl status database -d RACSB
    Instance RACSB1 is running on node oraclenode1
    Instance RACSB2 is running on node oraclenode2
    [oracle@oraclenode1 ~]$

    2. Stop RAC database and start in exclusive restrict mode

    [oracle@oraclenode1 ~]$ srvctl stop database -d RACSB
    [oracle@oraclenode1 ~]$ sqlplus / as sysdba

    SQL*Plus: Release 12.2.0.1.0 Production on Wed Sep 1 01:33:54 2021

    Copyright (c) 1982, 2016, Oracle.  All rights reserved.

    Connected to an idle instance.

    SQL> startup mount exclusive restrict and try to drop DB which will fail;
    ORACLE instance started.

    Total System Global Area 3070230528 bytes
    Fixed Size                  8625416 bytes
    Variable Size             838861560 bytes
    Database Buffers         2214592512 bytes
    Redo Buffers                8151040 bytes
    Database mounted.

    SQL> drop database;
    drop database
    *
    ERROR at line 1:
    ORA-01586: database must be mounted EXCLUSIVE and not open for this operation

    SQL> shut immediate;
    ORA-01109: database not open

    Database dismounted.
    ORACLE instance shut down.
    SQL> startup nomount;
    ORACLE instance started.

    Total System Global Area 3070230528 bytes
    Fixed Size                  8625416 bytes
    Variable Size             838861560 bytes
    Database Buffers         2214592512 bytes
    Redo Buffers                8151040 bytes

    ### only way to open your RAC database is EXCLUSIVE session is to set cluster_database=FALSE ###

    3. Set cluster_database=FALSE and start DB in exclusive restrict mode

    SQL> alter system set cluster_database=FALSE scope=spfile sid='*';

    System altered.

    SQL> shut immediate;
    ORA-01507: database not mounted

    ORACLE instance shut down.
    SQL> startup mount exclusive restrict;
    ORACLE instance started.

    Total System Global Area 3070230528 bytes
    Fixed Size                  8625416 bytes
    Variable Size             771752696 bytes
    Database Buffers         2281701376 bytes
    Redo Buffers                8151040 bytes
    Database mounted.
    SQL> select instance_name,status,logins from v$Instance;

    INSTANCE_NAME    STATUS       LOGINS
    ---------------- ------------ ----------
    RACSB1           MOUNTED      RESTRICTED

    4. Drop Database

    SQL> drop database;

    Database dropped.

    Disconnected from Oracle Database 12c Enterprise Edition Release 12.2.0.1.0 - 64bit Production
    SQL> exit

    5. Remove database from cluster

    [oracle@oraclenode1 ~]$ srvctl remove database -d RACSB
    Remove the database RACSB? (y/[n]) y
    [oracle@oraclenode1 ~]$

    Regards,
    Mallik

    🌟 Proud to be an Oracle ACE Pro! 🚀

    🌟 Proud to be an Oracle ACE Pro! 🚀 I’m excited to share my official Oracle ACE Profile with the Oracle community. 👨‍💻 Mallikarjun ...